2018 7 luglio

Supporto PHP nei vostri Plugin WordPress

Quando sviluppi il tuo plugin ti trovi davanti ad un problema, se usare o meno le nuove caratteristiche di PHP!

WordPress dalla versione 4.7 predilige PHP 7+ ma gira anche su versioni inferiori.

Oggi ho dato un occhiata alla pagina statistiche di WP da dove è possibile vedere le versioni più usate: ad ora ( 4.9 e 4.8 al 60% ) ma anche la versione PHP che sta girando sul server, attualmente è sul podio la ( 5.6 ) ma la ( 7.0 al 18.8% ) si sta facendo strada.

I server non aggiornati sono davvero troppi, ma nella creazione dei nostri plugin non dobbiamo sentirci dei “piccoli samaritani” mantenendo tutte le versioni, ma meglio utilizzare le migliorie aggiunte alle più recenti vers. di PHP.  😉

E a proposito segnalo l’articolo Handling old WordPress and PHP versions in your plugin di Mark Jaquith, che ha pensato di usare un controllo sulla versione di WP e PHP prima di far patire il plugin, tramite una classe: requirements-check.php disponibile sul suo profilo github.

Al posto di usare un controllo vi versione del tipo:


// verifica vella versione PHP < 7.1

if ( version_compare( $php_ver = phpversion(), '7.1.0', '<' ) ) {
$php_ver = explode( '.', $php_ver );
echo $php_ver[0] . '.' . $php_ver[1];
}
else { /*code*/ }

Condividi questo articolo

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

This site uses Akismet to reduce spam. Learn how your comment data is processed.